Toyota Rav4 EV Forum

It is currently Fri Nov 24, 2017 7:19 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: 2002 RAV4 EV not running
PostPosted: Wed Nov 01, 2017 8:14 pm 
Offline

Joined: Wed Nov 01, 2017 8:09 pm
Posts: 2
My 2002 RAV 4 EV is not running. It has 104,000 miles. Each time I have connected it to the charger, I get errors. The high and low side capacitors were replaced 2 years ago. And really, even when it was running it only had a 20 mile range. I'm no battery expert but I'm thinking that the pack has had a dead cell for sometime. It may have comprised the whole pack. Anyone know of a pack replacement possibility in Arizona?


Top
 Profile  
 
 Post subject: Re: 2002 RAV4 EV not running
PostPosted: Wed Nov 01, 2017 10:53 pm 
Offline

Joined: Thu Sep 26, 2013 4:49 am
Posts: 53
BatteryMD in Sacramento, CA is the authorized battery repair location. They used to have complete refurbished packs that they kept charged and cycled to keep them in good condition. Due to declining sales (only a few per year if I remember correctly), a few months ago they announced they would no longer be able to maintain those battery packs. It was no longer cost effective in terms of manpower and electricity costs. Contact them and see what they recommend that you do. Best wishes in getting it back on the road.

John


Top
 Profile  
 
 Post subject: Re: 2002 RAV4 EV not running
PostPosted: Thu Nov 02, 2017 12:08 am 
Offline

Joined: Wed Nov 01, 2017 8:09 pm
Posts: 2
Thanks John, I appreciate the info


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
© Toyota Rav4 EV Forum - part of the MyElectricCarForums.com Group