Weird Malfunction

Toyota Rav4 EV Forum

Help Support Toyota Rav4 EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Active member
Sep 12, 2022
Santa Barbara, San Jose
Yesterday I bought a beautiful 2012 RAV4 EV for my sister,

I test-drove it for 30 mins and everything worked perfectly. I started and stopped it multiple times with no issues. No errors. No warnings. I charged it for 15 mins or so during the test drive with no issues.

Last night I plugged in a slow aerovironment charger (3kW) and let it charge until charge time remaining said ZERO. At that moment the two yellow LEDs above the charge port were both on solid. I unplugged the charger with 128 miles showing on the Guess-O-Meter, then went to bed.

This morning, when I tried to start the car:

- The READY light flashed 5 times and then went out (as you all know, usually it flashes once and then stays on solid)

- The CHECK EV SYSTEM message appeared

- The power steering never activated

- The car would shift from P to N and back but not to R, D or B

- The Guess-o-meter read 129 Miles with climate control off.

- The motor coolant pump did not turn on (the one that usually be seen squirting fluid into the reservoir on the left side of the motor bay (looking into it)

- The climate control refused to run - no heat or AC although they could be selected "nothing happened"

- I did hear the clunk of the battery contactors (I believe)

- "most" of the warning lights were on

- I could step on the brake and press start (with the car running but not in READY ode and with the error showing) and the ready light would flash momentarily one time and then not turn back on

- The 12v battery voltage was 12.75 Volts

- When I plugged the charger back in "just to see what would happen" the charger stopped almost immediately with the error message "Charger stopped by System Malfunction"

I checked the speed sensor and it was not absolutely dry but not what I would call wet either. Parts of it were dry. Everything I could touch inside the hole looked and felt perfectly dry.

So I turned the car off and on 4 times. Then I waited 10 mins or so. Then I turned it off and on some more. Same behavior every time.

Then I waited 20 mins, and turned it on, and it started perfectly. All the climate control worked, The ready light was on. The power steering was working. The charger worked correctly again. The error message was gone.

I did notice that when I turned the car off this time it said the range was down to 126 miles and the 220v charge time estimate was now 10 mins.

I'm thinking of trying to get the dealer to take the car back within my 48 hour buyer's remorse period. Before I do, because It's a really nice car with 58,000 miles on it and apparently a very healthy battery, would any of you have similar experiences, or ideas of what might have been temporarily wrong with the car?

For example is it possible that somehow one cell in the battery went overvolt and the system had to drain it a bit before it would allow normal use?

Would you trust this car?

Thanks for any ideas.



I plugged the charger in after a short trip and the same malfunction appeared when the car became fully charged. Exact same malfunction.

This seems relevant:

but it's not clearing as easily as they describe.

Thanks for the feedback, both of you.

This guy is trying to solve a weird charging problem and a 12v drain problem etc.

At one point he swaps the Thermal ECU/Thermal Controller with one from a different car and his car begins to show the same symptoms the car I was thinking of buying showed:

Push start button with foot on the brake:
Ready On light blinks 5 times
Car won't go into drive
Check EV warning message

See the error at time 8:10 plus a few ...

The car in the video behaves exactly like the one I was looking at. BUT -this behavior only happened when the car I was looking at was charged to more than 95% and maybe only when fully charged, I'm not precisely sure. When the traction battery charge "bleeds off" by a few percent the car returned to operating normally.

Hokiematt, do you think the contactors might be OK and it's something to do with this module? Or is "5 READY blinks + CHECK EV" more generic and could be "anything?"

Alflash, would you think remote diagnostics would tell us anything?

Thanks for wasting your time on this, guys.
If this good/bad behavior is consistent with SOC, then it is likely not the contactors. Contactor faults are becoming more common on these vehicles with age, but would fail without regard to battery SOC. Yes, the READY flashing and check EV System warning is generic and simply means a problem with the Tesla side of things that is preventing the contactors from engaging.

I would suggest coordinating with Vlad to run remote diagnostics on this car; having data reduces guesswork :) But personally I would return this car to the dealer if still possible; there are enough of these vehicles out there for sale to not have to live with a quirky one.
SolarDaveGreen said:
Thanks for the feedback, both of you.

Alflash, would you think remote diagnostics would tell us anything?
Diagnosis* of Tesla systems can be useful and effective if a malfunction occurs during its implementation.
Recent examples of remote diagnostics ,
But, excuse me, but I don't understand why buy a car with problems? Fixing some problems can nearly double its cost...

*) Is this vehicle with VIN code ...1170 or is it another one?