HELP! Charging Issue - NOT Cables and probably not Battery

Toyota Rav4 EV Forum

Help Support Toyota Rav4 EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Apr 24, 2024
Tucson AZ
So, I happily purchased my 2014 RAV4 EV with 124K miles for several thousand under book. I knew it was 10 years old and had some battery degradation. Range was exactly as the small dealer promised: between 75 and 90 miles without and with Extended Charging respectively. We had charged it with a Level 2 at home and the stock Level 1 at work.

Then this past Friday, my wife plugged in at work and we realized the car was plugged in all day and hadn't charged. We thought that maybe the GFI in the 15amp power outlet had triggered, but we had 18 miles of range to get home and we only live a few miles away. I plugged in at home with my Level 2. But that night I realized that it wasn't charging past 18 miles anymore at all! We tried fiddling with settings and using both charging cables and got the same result: One blinking light indicating a low range but charging normally...but only long enough to get to about 19 miles. Once it got to that "max range" both lights would illuminate, just as normally when topped off. NO error messages pop up with any of this.

Once I get it to Max Range again, I try charging. Rather than an error, the 'amp count' on my Level 2 charger gets up to around 24 (out of 32) and then slowly trickles down to zero amps. Only then do I get the two solid lights indicating a full charge.

I took it to my local Toyota dealership, the one I called PRIOR TO purchasing the RAV4 EV to make sure they could service my car. They kept it overnight, then charged me $200, had the exact same problem with their ChargePoint Level 2 charger, and then told me not to bring it back. This was the same service manager that I was referred to by their service department that 'had experience with those cars' prior to my even buying it. He literally told me that his service techs urged him to get it off their lot right away.

I get referred by a friend and Tesla owner to GreenTec Battery. The guy there swallows hard and quotes me $15K plus $1K labor for a new battery. I tell him what's going on, then he tells me it's almost certainly NOT the battery because it's still drivable and the sudden drop in range is not simple battery degradation. He says to go get a new 12v battery and try that. About that time, I'm reading this forum, and I find Tony's thread about resetting the Range calculations by disconnecting the 12v battery after fully charging it (back up to 18 miles). I left it disconnected overnight and followed all Tony's steps. I reconnected in the morning and still had 19 miles of range. Should I even bother buying a new 12v? The current batter seems fine and is only 9 months old.

Given that 3 different chargers have resulted in the same issue, but that I AM able to charge...but only back to the new 'max', what is my recourse? I'm not mechanically inclined or I would try paying Alflash to diagnose and get in their myself. I really want to keep the car, but I can't keep it with a real-world range under 20 miles. Please help!


  • IMG_8246.MOV
    26.2 MB
This is the part that's making me scratch my head.
What you describe wouldn't be all that unusual for a coolant pump failure: the OBC would overheat, send a CAN msg to the Gateway to light the MIL on the instrument cluster. But you don't see that, so [shrug]. IDK.
For only the second time in a month I got a "Service at Dealership Immediately" message...but that quickly passed and it doesn't appear anymore.
It sounds like your 12V battery is fine.

My suggestion is to purchase a diagnostic cable from @asavage and install the Tesla Powertrain software on a laptop. The good news here is that your problem is repeatable, so it should (hopefully) be easy to diagnose. While charging, you can watch the live component statuses shown in the software. I suspect you'll either see an error reported from the charger which is causing it to stop charging prematurely (eg overtemp, undervoltage, etc), or the HV battery capacity reported by the BMS is substantially less than the nominal 35 kWhr, which could be due to a bad module in the pack (Gruber has a video on youtube where a single bad cell in an original Roadster was draining all the other parallel cells in the module, and the lowest capacity module - since they're all in series - sets the baseline for pack capacity). There are other less likely scenarios, but again your best roadmap will come from the powertrain software.
How do I proceed?
If reading those two threads (installing TPD on a laptop; build or acquire the adapter cable) doesn't sound like a direction you want to take, then accepting Tony's offer is probably your best course of action.

DIY repair isn't for everyone, and that's not a value judgement. The time required to acquire DIY skills is time that could be spent doing other things. Put another way: I wrote the basics on how to get and set up the diagnostic software for "free", and I can sell you a cable pre-made, but if what I wrote sounds too difficult and you need more direction at the start, then I think your current skill level may not be up to doing this.
So I returned after a month in Europe yesterday.

My housesitter thought she was being helpful and unplugged the car "because it's bad for electronics to be permanently plugged in."

Now the car is completely dark and plugging it in won't charge it or activate anything. I'm working with Al Savage on diagnostics, and hoping I can at least get my 20 miles of range back to tide me over with work and life tasks nearby. Will replacing the 12-volt battery at least get me that? Or has the problem now become more serious?
If there is no 12 V, nothing will work, as you found out.

Generally, people have had reasonably good luck with recharging the 12 V battery, unless the battery will no longer hold a charge. Lead-acid batteries really hate to be completely discharged, but I had the same situation with a body shop a year ago, and was able to revive my $300 AGM battery, and am still using it, and it is now six years old.

So, buy and replace the 12 V battery, or just recharge it. Either way should bring your car back to life.
Low voltage from the 12v CAN ruin the electronics. I'd disconnect the 12v battery until you either replace it or while you charge it. Reconnect when you have a battery showing a full charge.
Ok, I disconnected the battery and my friend is swinging by tomorrow morning to help me with the battery. Thanks for the intel guys!
Is available only in TPD v.1.1.42

I don't exclude that, thanks to the “efforts” of Tesla’s provocateurs, the code _w023 may not be detected/read by the program version 1.1.46 ...
Can you elaborate on this? I only recall the spurious BMS_W023 that can happen, and that can be cleared. I want to know more about "ruin".
I may have been remembering that problem, not knowing it was "clearable". I do know that low voltage can cause all sorts of weird problems. Even if it doesn't completely "ruin" the electronics, no sense in subjecting the car to the whole process of charging the battery or letting it sit at a low voltage.
Ok the car is powered up and I have the cable.

Post a screenshot of TPD, configured with the "Perspective" showing at least:

(Access these under View in the top Nav bar)

Alert List (two panes)
Pump Tool Monitor (not "Pump Tool")
Battery & Charger -> Battery
Live Data -> Charger

Take this (or multiple) screenshots both with car in Ready, and when a charging cable is plugged in. Post the screenshots here.
The car is charging using the OEM household 15a charger. 1 hour remaining. No error messages but I have 3 bars on the battery graph and 24 miles of range (which is higher than it was last I checked).