Another DOA Rav, time to troubleshoot- seems OBC fuses are fine ;-(

Toyota Rav4 EV Forum

Help Support Toyota Rav4 EV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Well-known member
Aug 27, 2013
SoCal-Burbank Area
Well its about that time for our Rav to wig out now (and it has a beautiful factory Pearl White paint job too) but the wife was just 7 houses down the street at her parents, started it up, was pulling out of the driveway and it just wigged out with the dreaded EV error and take to stealership warning. Since we have the full Platimum / ext coverage... I called Toyota/ Hamer and they picked it up ASAP... then looked at it.. scratched their heads... said its the battery... and $17k and Bob's your Uncle and you'll be fine!! :D

But that won't fly.. knowing we've taken care of this car (custom BMS monitor, etc).. and the pack was in excellent condition and 125+ miles still of range.. I'm thinking or leaning towards the contactors but who knows.. so I had them bring it back up here and she sits.. I have the full Techstream SW and can reset the front panel or anything on the Toy side.. and have the TDP for checking on things...

So.. here we start.. as I've said or mentioned before... I've had (and was the OG tester/helper,etc) for the JaDEMO unit.. so 1st thing was I pulled it off (no one has this type of unit anymore but me, doubt even Tony still has this alpha unit still running)... but even after removal... and a full clear of codes.. nada.. still no READY..

So talking with asavage and looking at his pics.. I just went out and did a quick J-plug/OBC test to check fuses.... they all seem good :cry: DAMN!

So.. that leaves next steps then..
Fun times are ahead..
Here are some pics from testing...

So to me, they check out OK? Also the battery compartment underneath was very clean / water tight. Nothing seemed wrong..

NIce DMM :)

(for others that find this thread later: testing for OBC failed AC input fuse(s): )


I think that you mentioned somewhere else that you have TPD 1.1.46 installed, and that you have (at least) a BMS_f071?

Post screenshots from TPD.
It's a bit confusing since you've posted across four different threads, but (correct me if I'm wrong) your problem is you can't charge and also recently while driving your RAV4 stopped (presumably shifted to N/lost READY mode). Your measurements show that the input fuses to the charger are good, but quite honestly this is a red herring, because a bad OBC is not going to keep you from being able to drive.

Have you tried cycling power off/on five times in a row quickly? This will normally clear the fault that occurs when the drive unit is experiencing coolant leakage, and allow the system to return to READY/drive, at least until more catastrophic damage occurs.

IMHO, your most likely candidates are a bad contactor, wire harness damage from rodents, and coolant infiltration in the drive unit inverter. I give 'bad contactors' an 80% likelihood.

Once you've got TPD running, post a screenshot; the most important info will be the main contactor status, and isolation resistance, in addition to any fault codes.
I'm only posting here now the details for my issue but you've nailed a few things that have come across my mind about what the potential issues could be (I'm no stranger to EV's and systems) but I've only started to dig into my problems here this weekend really because of time and the Rav just got back here from Hammer.

I've done every possible reset, gateway flash, Techstream reset, power off/on, etc there is under the sun.. and I can even reset this thing so there is NO check EV on the dash... but also no READY light too :ROFLMAO: and it just won't come on.

I've checked EVERY single fuse, and just about every wiring harness (within reason) while i was taking off the JaDEmo and now let me go into the part about your ""RODENT" remark...

My buddy Tony Tam owns EVFixMe down in Costa Mesa and right before we took off for Texas for the eclipse, i drove down and had him do the front and rear motors in the S (if i only had a lift!!) . Well guess what, he found a harness with FRESS bite marks but nothing serious... so we taped it up.. and away i went... but i also sprayed a BUNCH of peppermint oil all around / underneeth / inside the S, etc... to deter any rodents (darn cats!! what good are they??)

Also i did the same to the Rav... but away we went to see the eclipse in TX... come back.. and a few days later, shes driving around all fine, stop by her parents.. and she gets back in, starts up.. pulls out and BAM! DOA

Now, is it rodents?? Is it a bad contactor??? water pump??? Who knows... I've been a part of this group and hacking Leaf's and Ravs along time...

I've personally seen 2 friends on here... one sold another Rav to one.. pristine shape... they go do the swap.. he's driving it home and BAM!! car is DOA.... turns out its the water pump, what luck is that? Toyota had it for months trying to figure it out.

Anyways... my gut tells me its possibly the contactors.. but I'm hoping its the pumps or something. There's been ZERO water leaks or fluid loss in this thing. I paid cash for it since it was new at Carson Toyota and owned it its whole life so I know it ;)

I'll pull the speed sensor in a bit and we'll see. I appreciate everyone's input and feedback. It could be a chewed harness somewhere.

That's what sucks about modern cars....
Fun times!
Last edited:
Ok so I did a hard reset / 12v pull on the entire car.. but before I did I was getting "CHECK EV" etc and also attached is the TDP screenshot with the BMS FAULT which is strange because I've never seen it show that before, only standby.

Anyways, pulled everything possible, waited 10... chilled.. attached battery and powered up/ booted up with my power supply also on the battery with 14.4v at the terminals (pic shown)... and decent amperage pulling.

Now at this point, I can step and hold on the brake til the cows come home and press and press the start and no errors show any where. Attached are pics of the current TDP and front dash with NO check ev and no READY light either :cry:

I've tested the pumps on the TDP and they seem to work. I know this car pretty well and that clickety click you kinda hear before the main contactors isn't happening.. when powering on the READY doesn't even appear or flash at all.

Its like a ghost...20240429_183333.jpg20240429_183357.jpgRav-2600-TPD-Test2-Hardreset.JPGRav-2600-TPD-Test1.JPG
Apropos of nothing, I note that your battery terminals look awful. My mother's 25-year-old '99 Sienna's terminals look better than that. For the negative, you can replace the terminal without doing any cable work -- it's a bolt-on -- and yours has all the plating gone on it, eaten up.

That positive terminal . . . run a garden hose over it, please :(

Everything underhood can stand garden hose water. At least, the OEM stuff (no telling about the JDemo).
alflash has an amusing vid that highlights that while TPD states that BMS_f071 "is always accompanied by another alert", TPD doesn't show another alert. Nice software, guys!

From what I can tell, BMS_f071 can reflect a collection of issues, from a HV Isolation problem (skip down to the English section) (typically in the LDU, but it could be in any HV system) to actual battery cell/brick/module/BMS/contactor issues.

TPD reports the isolation resistance is 1.4 and 1.5Mohm, so I'm gonna stick my neck out and say you've got an HV Isolation issue. The most common cause is water in the stator of the DU, but there's a troubleshooting tree from Tesla for the Model S that you can run down, if you want. Basically, you get to disconnect the various HV subsystems and test their HV isolation, one at a time.

But it it were me, I'd pull that LDU speed sensor and look for blue coolant drops.

My RAV4's HV system isolation resistance today is 2.3Mohm, which seems pretty low to me.

Last edited:
The reported isolation resistance value is low; normally before the contactors close, it should be over 3000 kOhms. Once contactors are closed, usually the system shows around 2000 kOhms. It will be unhappy below 1000 kOhms. Since you've already been inside the battery junction box, one option could be to remove the two bolts for the motor HV feed and note the impact on isolation resistance, then repeat by removing the two bolts for the other HV feed.

Low hanging fruit: pull the speed sensor and check for coolant, it's a two minute job, and will let you know if perhaps the coolant manifold modification is in your future.

I'm still leaning towards a contactor issue. With no isolation faults being reported in TPD, that seems the best explanation to cover all your symptoms, and contactor replacement has been a fairly regular repair for owners these last few years.

Where are you located? I'll be in Costa Mesa next week, if you're not too far away I could swing by some evening; I have some additional CAN tools that could be useful.
Good morning team..

Welp.. I pulled the sensor and BAM! Don't know to be happy or sad but now at least I have something tangible and can work with knowing now there's coolant in the motor :cry:

thing is, Toyota just replaced this motor only a few years ago (covid timeline i believe) and if I'm not mistaken the motors are covered still under the plat/ext war??

Anyways, here's the pics and there's defiantly moisture / liquid in there.

P.S. hookie: I'm up here in the valley / Burbank area. PM me if you want but i think we may have found the issue here :(

Toyota just replaced this motor only a few years ago (covid timeline i believe) and if I'm not mistaken the motors are covered still under the plat/ext war??
No. The warranty for the part is the standard Toyota part warranty. Your extended warranty might buy you another LDU (if the cost of doing so is less than their estimate of your vehicle's value), but it will decrement your remaining extended warranty balance.

Put another way, the extended warranty has a limit (the value of your vehicle) and each time you use it, the repair cost is subtracted from that limit, until the warranty expires or they deem the cost of the last repair to "total" the car and they then refuse to pay for the repair, instead offering to refund the remainder of your warranty's balance.

[later: the remainder of this post has been moved to a separate thread.]
Last edited:
alflash has an amusing vid that highlights that while TPD states that BMS_f071 "is always accompanied by another alert", TPD doesn't show another alert. Nice software, guys!

From what I can tell, BMS_f071 can reflect a collection of issues, from a HV Isolation problem (skip down to the English section) (typically in the LDU, but it could be in any HV system) to actual battery cell/brick/module/BMS/contactor issues. ...
1/2 OFF.
Note. The cause of the BMS_f071 code (alert) may be a critical malfunction in any Tesla system, not just in the Inverter
For example, one of the reasons for this code
shown in
Last edited:
Thanks for all the great info! I really appreciate it, I just called my service manager at Toyota and he was shocked to hear about that and the motor was replaced in Nov-2020 and only has 9k miles on it so that's how much we drive it. He's re-entering the notes / motor issue now with TFS and I'll push from that angle first.

If they don't want to replace the motor, then I'll get my remaining $$$'s back on the warranty because I have until 2026 with it and its useless at this point to even have it (towing i get through USAA/AAA) and I'll work on the motor issue myself.

But if toyota DOES swap it out, 1st thing I'll do is the coolant bypass in one way shape or form ;)
So a quick update after getting some advice on here on to try a few additional things. Some aren't convinceted its the motor and now I'm leaning that way too (looking like the contactors or welded / stuck??).. so i tried a few tests..

Trying to power up with the HV motor leads connected, WITHOUT them connected, with NOTHING connected underneath , etc.. and see what the ISO values are and still I can't get the READY or contactors to kick in.

If I attempt to plug in then I get a 062-contactor PS issue.. Here's the vid I made which is just easier ;)

Some pics if that's easier.. but I'm thinking it's in the pack..
No errors on TS...

Error with everything connected... all HV is hooked up.. and tried to charge..

And if nothing is connected and powered up...

I'm on the road, and haven't watched your video. Looking at the screenshots, you have 1.3Mohm in one shot, and the BMS error. I believe the threshold is 1.8M, so that doesn't surprise me.

You have 3.3Mohm in the other screenshot, and no BMS error . . . and the charger is trying to update? That doesn't look right.

OK, I watched the video.
So, from my point of view, you are in unexplored territory; the iso test is valid with various HV circuits disconnected, but everything else you see may or may not be valid, because other systems will only have 12v and not HV, and they're not going to necessarily report things. You're not seeing alerts on TPD, which does surprise me but only a little bit.

I think if I understand what you've done, you can get the iso above 1.8M by disconnecting the LDU. And you know there is water in the LDU. If it was me, I would concentrate on fixing what you know is wrong, and not get too twisted about not getting any other definitive test results, using non-standard testing practices.
Last edited:
The contactors within the battery pack assembly have their own 12V feed, separate from the BMS power. There should be a 15A fuse in one of the underhood fuse boxes (fuzzy memory thinks it's driver's side) labeled CONTACTOR - it's probably worth making sure that fuse is good. After the fuse, the power goes to a relay and then the pyrotechnic safety switch (inside dash, behind radio) before powering the contactors.

Unfortunately I'm out of town for the next few weeks; perhaps another forum member could offer to pull their contactor fuse and try starting their RAV and/or charge, and report the symptoms/TPD codes to see if they're similar.
I had my HV disconnnect out, and had to connect 12v to test some TPD cables, and while I got some errors, none were that 062.

Of course, the HVIL loop was broken/open with the disconnect out, so that's a different scenario.
I checked that relay bank with the 4 indv fuses and the 1 - 15a Contactor fuse and its fine and getting full battery power. Yeah short of dropping the pack (which I really can't do) I'm thinking its inside or a welded unit. I smell something 'burnt" or not good / electrical fried kinda when i stick my nose down where the fuse is under the seat and same up under the battery / fuse box are. Something smells off... :oops:

Thing that sucks is it was such a short trip and I have the dash cam footage.. it was nothing major, she gets in, goes down the street to her parent's house... gets out. power's off (darn her for doing that!)... then comes right back out... powers up.. then just starts to creep out and BAM!..

Never again to go into READY..